RadarURL

유닉스/리눅스
2023.05.02 08:06

리눅스 inodes full 이슈 해결 방법

조회 수 3278 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

가 크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

가 크게 작게 위로 아래로 댓글로 가기 인쇄

소스 형상관리(SVN)로 사용하는 서버(xxx.xxx.xxx.xxx)에서, svn 사용 시(소스 check out등)

 

“svn: E204900: Can't find a temporary directory: Internal error”

 

와 같은 에러가 발생하는 경우  원인을 찾아본 결과, 서버 디스크 용량 full 문제였는데, 하드디스크 용량 부족의 문제가 아니라,

 

서버에서 설정되어 있는 inodes 개수가 100% 사용되는 것이 문제였습니다.

 

Inodes는 서버에서 파일의 정보를 담고 있는 구조체 데이터이며, 이는 서버에서 열 수 있는 파일의 개수와 연관이 있습니다.

 

따라서, inodes 사용률이 100%라는 것은, 서버에서 생성할 수 있는 파일의 개수를 모두 사용하고 있다는 것이며,

 

이는 하드 디스크의 데이터 용량과는 무관하게, 더 이상 새로운 파일을 생성할 수 없음을 뜻합니다.

 

SVN에서 소스를 체크아웃 할 경우에도, 내부적으로 임시파일을 생성하는 절차가 있으며, 위와 같은 사유로, 파일을 생성할 수 없으므로,

 

상기 이슈가 발생하였습니다.

 

Inodes의 사용률을 확인하는 방법 및 사용률 해소 방법은 다음과 같습니다.

 

1.       Inodes 사용률 확인 : df –i

2.       1. 번 결과에서 사용률이 가장 높은 디렉토리로 이동하여 for i in *; do echo -e "$(find $i | wc -l)\t$i"; done | sort –n 명령 실행

3.       2. 번 결과에서 사용률이 가장 높은 디렉토리로 이동하여 2. 번 명령 반복

4.       3. 번을 반복 실행하여 최종 dept의 디렉토리까지 이동하여 파일 내용을 확인한 후, 불필요한 파일일 경우 삭제

5.       1. 번 명령을 통해 inodes 사용률 감소 확인

 

출처 : https://hyunsoft.tistory.com/entry/%EB%A6%AC%EB%88%85%EC%8A%A4-inodes-full-%EC%9D%B4%EC%8A%88-%ED%95%B4%EA%B2%B0-%EB%B0%A9%EB%B2%95

?

공부 게시판

공부에 도움되는 글을 올려주세요.

  1. No Image notice by 처누 2003/08/18 by 처누
    Views 1756196 

    [공지] 공부 게시판 입니다.

  2. [Rocky Linux 9] /home 용량 줄이고 /root 용량 늘리기

  3. [Rocky Linux] LVM 환경에서 /root 파티션 공간 부족 해결

  4. [Linux/Rocky] SSH Root 로그인하는 방법 (root 접속 허용)

  5. 리눅스 서버 설치 중 에러 "Failed to find a suitable stage1 device"

  6. Linux 11 . Linux 설치 시 lvm 수동설정

  7. [Rocky Linux] 누구나 쉽게 따라하는 Rocky Linux 9.0 OS 다운로드 및 설치 방법~!!

  8. Linux/Rocky Linux Rocky Linux : Composer 설치

  9. [Rocky Linux] 록키 리눅스 최신 업데이트 적용 방법

  10. rocky linux 커널 업데이트

  11. Clonezilla(클론질라) 백업파일 하드디스크로 복구 방법

  12. 클론질라 사용 방법 - OS 이미지 백업 CloneZilla

  13. [Linux / Rocky] FTP 접속 관련 설정 실습 예제

  14. Could not reliably determine the server's fully qualified domain name

  15. [아파치] 아파치 웹서버에 .htaccess 파일 설정하는 방법

  16. [Linux] Apache web server의 rewrite module 사용하기 [출처] [Linux] Apache web server의 rewrite module 사용하기|작성자 g00dmoney

  17. 록키 리눅스 9.1에서 apache, mysql, PHP 설치

  18. [권한문제] 라이믹스 Fatal error: Uncaught Rhymix\Framework\Exception: Cannot write template cache file

  19. 라이믹스 php 에러 표시

  20. Rocky Linux - 라이믹스(Rhymix) 설치하기

  21. 라이믹스(Rhymix) 매뉴얼

Board Pagination Prev 1 2 3 4 5 6 7 8 9 10 Next
/ 10


즐겨찾기 (가족)

JAESOO's HOMEPAGE


장여은 홈페이지


장여희 홈페이지


장여원 홈페이지


즐겨찾기 (업무)

알리카페 홀릭

숭실대 컴퓨터 통신연구실 (서창진)

말레이시아 KL Sentral 한국인 GuestHouse


즐겨찾기 (취미)

어드민아이디

유에코 사랑회

아스가르드 좋은사람/나쁜사람

JServer.kr

제이서버 메타블로그

재수 티스토리


즐겨찾기 (강의, 커뮤니티)

재수 강의 홈페이지


한소리


VTMODE.COM


숭실대 인공지능학과


숭실대 통신연구실


베너